Easily add libraries to Eclipse Java Oxygen

I know there are post about JAVA libraries in Eclipse and I used a way to add some .jar files (like apache.poi and jsoup) to my project. My question is: Where do we have to put those libraries and what settings do we have to change, so to make the li...
more »

2017-12-03 22:12 (1) Answers

Sphinx4 helloworld indexOutOfBoundException

i'm running the HelloWorld code give by sphinx. It starts and waits for me to say something in the mic, but when i start speaking it gives me this error: Exception in thread "main" java.lang.IndexOutOfBoundsException: Index: 110, Size: 110 at ja...
more »

2017-12-03 14:12 (0) Answers

Eclipse won't open after installing openjfx

I was attempting to use JavaFX, and I found that I needed to install the openjfx package, as the regular openJDK8 didn't come with the JavaFX files. However, since I did that Eclipse no longer opens. Instead, it crashes with the following crash log a...
more »

2017-12-03 04:12 (0) Answers

Disable Gerrit for repository in Eclipse

I accidentally enabled Gerrit for one of my Git repositories when developing in Eclipse. Is there any way to disable this? I'm primarily asking because it seems to have the side-effect of slowing down my staging processing within Eclipse for that r...
more »

2017-12-03 02:12 (2) Answers

Cross formatter java/html for eclipse and intellij

In the company I works for by default the IDE is Eclipse, but we have some new products using android. Because of Android Studio some developers are using IntelliJ, so I'm looking for an effective way to keep the same code formatting between Eclipse ...
more »

2017-12-02 19:12 (0) Answers

Problems when trying to persist an Entity

I'm getting errors when trying to persist my entity class into Oracle database. Here is my Entity class package com.airline.models; import java.io.Serializable; import java.time.LocalDate; import javax.persistence.Entity; import javax.persiste...
more »

2017-12-02 11:12 (0) Answers

JPA sequences using autogeneration

I have created for an Entity an auto generated id like: @Id @GeneratedValue(strategy = GenerationType.AUTO) private Integer id; and when tried to persist the entity I got the error: Exception [EclipseLink-4002] (Eclipse Persistence Servi...
more »

2017-12-02 11:12 (0) Answers

How to replace google dependencies with jar file

I am going to implement google firebase messaging to my android project. Google documentation offers using dependencies. I am confused if I can import JAR files instead of dependencies or JAR and dependencies are both needed? Would importing JAR file...
more »

2017-12-01 19:12 (1) Answers

Move packages from android studio to eclipse

I would like to use the android.os package from Android Studio and SDK in eclipse. This is so that I can run a java application on my computer to take data off of a sd card on a phone when it is plugged in via USB. I have both Android Studio and Ecli...
more »

2017-11-30 22:11 (1) Answers

"Run on Server" on eclipse information

I have a question on "Run on Server" functionnality in eclipse , if you have a maven project and a server configured in eclipse (Wildfly for exemple) it's necessary to build with "Maven build" in eclipse before deploying with "Run on server function ...
more »

2017-11-30 20:11 (0) Answers

Unable to set GridLayout to a Composite container

I am unable to set a GridLayout to a Composite Container in a Plugin project in Eclipse Neon 3. The code I am writing for setting the layout to the container is: private Composite container; @Override public void createControl(Composite parent) {...
more »

2017-11-30 12:11 (1) Answers

spring boot app - beanUtils not found

In eclipse I create a new spring boot starter project. The Spring Boot Version is 1.5.9.RELEASE and the dependency I include is the spring-boot-starter-web (this is all done by the Spring Project wizard in eclipse, so likely no error there). When I r...
more »

2017-11-30 11:11 (0) Answers

Running project in IntelliJ

I have one application based on Maven + Spring. It's a Java web application using java. this is the pom.xml i'm using: <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="h...
more »

2017-11-30 10:11 (1) Answers

Error occured while opening Eclipse(See log file)

I am new to Java. Currently I am facing problem with eclipse. I am unable to open Eclipse. I have tried to solve it by downloading the latest Eclipse but it does not help me. Here I am providing the log file. I can't understand where the problem loca...
more »

2017-11-30 09:11 (0) Answers

How to write from eclipse's jar to Jmeter's log

I would like to create jar in eclipse and to use it in Jmeter. but if I want to write to Jmeter log how can I do it? for example if I have the next function int sum (int a, int b) { return a + b; } but I would like to add "the value of a is" +...
more »

2017-11-29 10:11 (1) Answers

Pydev requires latest version of Eclipse

I have downloaded Eclipse Oxygen and installed it yesterday. When I try to install PyDev, I get an error: This version of PyDev requires a newer version of Eclipse to run. The latest version is not even out yet until next year. What am I doing...
more »

2017-11-29 09:11 (0) Answers

I Cant Run Opencv Project in other machines

I have a project whit opencv on my machine that is running ok, it works and does what it should do. In my machine I installed the opencv libraries. The problem is that when I want to run the program on another Linux machine I get this error: Error...
more »

2017-11-28 23:11 (0) Answers

Cannot call Class with package name in PL file

I have create a PL for example : vhpFO1ui.pl with PROLIB syntax and add (arl_listUI.r) into it. PROPATH in .ini are set to the PL file directory path. There are 2 cases : a program called arl_listUI.r in PL it returns an error. (source with packag...
more »

2017-11-28 11:11 (1) Answers

Materialize Idempiere Version 5.1 Error

I am really new in the world programmer and pardon me if I have bad English. I want to ask how do you materialize idempiere? I am already use Eclipse Neon 4.6 use Buckminster updated download from Eclipse http://download.eclipse.org/tools/buckminster...
more »

2017-11-28 03:11 (1) Answers