Conditional gem requirement - can a gem require a gem based on its depender's other gems?

Question

I have an app that requires my own sharepoint gem, and I'm upgrading the app from Rails 4.1 to 4.2. My sharepoint gem now requires rails-deprecated_sanitizer to be present (which it is in my app, but that's just a happy coincidence), so it can be explicitly required in one file.

sharepoint requires rails with no version restrictions. Is there a way for sharepoint to require rails-deprecated_sanitizer if the rails version it's included with is >= 4.2?


Show source
| rubygems   | ruby-on-rails   2017-11-29 22:11 0 Answers

Answers to Conditional gem requirement - can a gem require a gem based on its depender's other gems? ( 0 )

Leave a reply to - Conditional gem requirement - can a gem require a gem based on its depender's other gems?

◀ Go back