What Am I missing - OCI8.DLL not found

Question

I have installed Ruby and OCI8 gem according to various posts in SO. I also have experience correcting others setups. I also installed it in my desktop in Windows and also MAC and also have it up and running. But I am unable to replicate it in the AWS environment.. I am consistently getting

 OCI.DLL: 126(The specified module could not be found.  ) (LoadError)

My Path is

PATH=C:\ConEmu\App\ConEmu\ConEmu\Scripts;C:\ConEmu\App\ConEmu;C:\ConEmu\App\ConEmu\ConEmu;C:\ProgramData\Oracle\Java\javapath;C:\instantclient_12_1;C:\InstantClient;C:\InstantClient\instantclient_12_1;C:\Ruby200\bin;C:\Ruby200\DevKit\bin;C:\instantclient_12_1;C:\InstantClient;C:\InstantClient\instantclient_12_1;

My instantclient installation with merging of OCI Basic and OCI SDK packages are in instantclient libraries[did it two places just to double check]

is in both C:\instantclient_12_1 and C:\InstantClient\instantclient_12_1;


Show source
| ruby   | rubygems   | oracle   | oci8   | amazon-ec2-windows   2017-01-04 04:01 0 Answers

Answers ( 0 )

◀ Go back