How to require ruby gems in Jupyter notebook?

Question

I've been looking all over the internet with no answer. Does anyone know how to require ruby gems in Jupyter notebook? I tried require'byebug' and require 'pry' with no use.

I get this error when I try require 'byebug':

*** No sourcefile available for (pry)

And this error when I try require 'pry':

From: (pry) @ line 923 Object#divide:

I'm using a local notebook and not the cloud version of course.

EDIT: I even tried setting the absolute path when requiring byebug require '/usr/local/lib/ruby/gems/2.3.0/gems/byebug-9.0.6'.


Show source
| ruby   | rubygems   | jupyter   | jupyter-notebook   2017-01-04 13:01 0 Answers

Answers ( 0 )

◀ Go back