Why does gem dependency list a gem I have commented out in my Gemfile?

Question

I'm trying to eliminate a dependency on JSON-1.8.3 that is wreaking havoc with my build. I deleted my Gemfile.lock and then commented out the only item (bootstrap-sass) in my Gemfile that had that dependency ...

# Bundle edge Rails instead: gem 'rails', github: 'rails/rails'
gem 'rails'  #, '~> 4.2.7.1'
# Use SCSS for stylesheets
gem 'sass-rails', '~> 5.0'
# Use Uglifier as compressor for JavaScript assets
gem 'uglifier', '>= 1.3.0'
# Use CoffeeScript for .coffee assets and views
gem 'coffee-rails', '~> 4.2'
# See https://github.com/rails/execjs#readme for more supported runtimes
# gem 'therubyracer', platforms: :ruby

# Use jquery as the JavaScript library
gem 'jquery-rails'
# Turbolinks makes navigating your web application faster. Read more: https://github.com/turbolinks/turbolinks
gem 'turbolinks', '~> 5'
# Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder
gem 'jbuilder', '~> 2.5'
# Use Redis adapter to run Action Cable in production
# gem 'redis', '~> 3.0'

gem 'uuids' 
gem 'addressable'
gem 'pg'
gem 'pundit'
gem 'omniauth-oauth2', '~> 1.3.1'
gem 'omniauth-google-oauth2'
gem 'omniauth-facebook'
gem 'omniauth-twitter'
gem 'omniauth-linkedin-oauth2'
gem 'jquery-ui-rails'
gem 'jquery-cookie-rails'  
gem 'will_paginate'
#gem 'bootstrap-sass'
gem 'autoprefixer-rails'
gem 'compass-rails'
gem 'pdf-reader' 
gem 'jquery-turbolinks'
gem 'activerecord-import' 
gem 'w3c_validators'
gem 'whenever', :require => false
gem 'roo-xls'
gem 'socksify'

But when I run gem dependency, it still lists bootstrap-sass-3.3.7...

localhost:myproject davea$ gem dependency
Gem Ascii85-1.0.2
  bundler (>= 1.0.0, development)
  minitest (>= 2.6.0, development)
  rake (>= 0.9.2, development)

Gem actioncable-5.0.0.1
  actionpack (= 5.0.0.1)
  blade (~> 0.5.1, development)
  nio4r (~> 1.2)
  websocket-driver (~> 0.6.1)

Gem actioncable-5.0.1
  actionpack (= 5.0.1)
  blade (~> 0.5.1, development)
  nio4r (~> 1.2)
  websocket-driver (~> 0.6.1)

Gem actionmailer-5.0.0.1
  actionpack (= 5.0.0.1)
  actionview (= 5.0.0.1)
  activejob (= 5.0.0.1)
  mail (>= 2.5.4, ~> 2.5)
  rails-dom-testing (~> 2.0)

Gem actionmailer-5.0.1
  actionpack (= 5.0.1)
  actionview (= 5.0.1)
  activejob (= 5.0.1)
  mail (>= 2.5.4, ~> 2.5)
  rails-dom-testing (~> 2.0)

Gem actionpack-5.0.0.1
  actionview (= 5.0.0.1)
  activemodel (= 5.0.0.1, development)
  activesupport (= 5.0.0.1)
  rack (~> 2.0)
  rack-test (~> 0.6.3)
  rails-dom-testing (~> 2.0)
  rails-html-sanitizer (>= 1.0.2, ~> 1.0)

Gem actionpack-5.0.1
  actionview (= 5.0.1)
  activemodel (= 5.0.1, development)
  activesupport (= 5.0.1)
  rack (~> 2.0)
  rack-test (~> 0.6.3)
  rails-dom-testing (~> 2.0)
  rails-html-sanitizer (>= 1.0.2, ~> 1.0)

Gem actionview-5.0.0.1
  actionpack (= 5.0.0.1, development)
  activemodel (= 5.0.0.1, development)
  activesupport (= 5.0.0.1)
  builder (~> 3.1)
  erubis (~> 2.7.0)
  rails-dom-testing (~> 2.0)
  rails-html-sanitizer (>= 1.0.2, ~> 1.0)

Gem actionview-5.0.1
  actionpack (= 5.0.1, development)
  activemodel (= 5.0.1, development)
  activesupport (= 5.0.1)
  builder (~> 3.1)
  erubis (~> 2.7.0)
  rails-dom-testing (~> 2.0)
  rails-html-sanitizer (>= 1.0.2, ~> 1.0)

Gem activejob-5.0.0.1
  activesupport (= 5.0.0.1)
  globalid (>= 0.3.6)

Gem activejob-5.0.1
  activesupport (= 5.0.1)
  globalid (>= 0.3.6)

Gem activemodel-5.0.0.1
  activesupport (= 5.0.0.1)

Gem activemodel-5.0.1
  activesupport (= 5.0.1)

Gem activerecord-5.0.0.1
  activemodel (= 5.0.0.1)
  activesupport (= 5.0.0.1)
  arel (~> 7.0)

Gem activerecord-5.0.1
  activemodel (= 5.0.1)
  activesupport (= 5.0.1)
  arel (~> 7.0)

Gem activesupport-5.0.0.1
  concurrent-ruby (>= 1.0.2, ~> 1.0)
  i18n (~> 0.7)
  minitest (~> 5.1)
  tzinfo (~> 1.1)

Gem activesupport-5.0.1
  concurrent-ruby (>= 1.0.2, ~> 1.0)
  i18n (~> 0.7)
  minitest (~> 5.1)
  tzinfo (~> 1.1)

Gem afm-0.2.2
  minitest (~> 5.3, development)
  rake (~> 10.3, development)
  rdoc (~> 4.1, development)

Gem arel-6.0.4
  minitest (~> 5.4, development)
  rake (>= 0, development)
  rdoc (~> 4.0, development)

Gem arel-7.1.4
  minitest (~> 5.4, development)
  rake (>= 0, development)
  rdoc (~> 4.0, development)

Gem autoprefixer-rails-6.5.1
  compass (>= 0, development)
  execjs (>= 0)
  rails (>= 0, development)
  rake (>= 0, development)
  rspec-rails (>= 0, development)

Gem bcrypt-3.1.11
  rake-compiler (~> 0.9.2, development)
  rdoc (~> 3.12, development)
  rspec (>= 3, development)

Gem bcrypt-ruby-3.1.5
  bcrypt (>= 3.1.3)
  rake-compiler (~> 0.9.2, development)
  rdoc (~> 3.12, development)
  rspec (>= 0, development)

Gem bigdecimal-1.3.0
  minitest (~> 4.7.5, development)
  rake (~> 10.0, development)
  rake-compiler (~> 0.9, development)

Gem bootstrap-sass-3.3.7
  actionpack (>= 4.1.5, development)
  activesupport (>= 4.1.5, development)
  autoprefixer-rails (>= 5.2.1)
  capybara (>= 2.5.0, development)
  jquery-rails (>= 3.1.0, development)
  json (>= 1.8.1, development)
  minitest (~> 5.8, development)
  minitest-reporters (~> 1.1, development)
  poltergeist (>= 0, development)
  sass (>= 3.3.4)
  slim-rails (>= 0, development)
  sprockets-rails (>= 2.1.3, development)
  term-ansicolor (>= 0, development)
  uglifier (>= 0, development)

Gem builder-3.2.2

Gem bundler-1.13.7
  automatiek (~> 0.1.0, development)
  mustache (= 0.99.6, development)
  rake (~> 10.0, development)
  rdiscount (~> 2.2, development)
  ronn (~> 0.7.3, development)
  rspec (~> 3.5, development)

Gem bundler-unload-1.0.2
  bundler (>= 0, development)

Gem byebug-9.0.6
  bundler (~> 1.7, development)

Gem chronic-0.10.2
  activesupport (>= 0, development)
  minitest (~> 5.0, development)
  rake (>= 0, development)
  simplecov (>= 0, development)

Gem chunky_png-1.3.8
  rake (>= 0, development)
  rspec (~> 3, development)

Gem coffee-rails-4.2.1
  coffee-script (>= 2.2.0)
  railties (< 5.2.x, >= 4.0.0)

Gem coffee-script-2.4.1
  coffee-script-source (>= 0)
  execjs (>= 0)
  json (>= 0, development)
  rake (>= 0, development)

Gem coffee-script-source-1.10.0

Gem coffee-script-source-1.12.2

Gem colorize-0.8.1
  codeclimate-test-reporter (~> 0.4, development)
  minitest (~> 5.0, development)
  rake (~> 10.0, development)

Gem concurrent-ruby-1.0.2

Gem concurrent-ruby-1.0.4

Gem daemons-1.2.4
  pry-byebug (~> 0, development)
  rake (~> 0, development)
  rspec (~> 3.1, development)
  simplecov (~> 0, development)

Gem debug_inspector-0.0.2

Gem did_you_mean-1.1.0
  bundler (>= 0, development)
  minitest (>= 0, development)
  rake (>= 0, development)

Gem erubis-2.7.0

Gem eventmachine-1.2.1
  rake-compiler (~> 0.9.5, development)
  rake-compiler-dock (~> 0.5.1, development)
  test-unit (~> 2.0, development)

Gem execjs-2.7.0
  rake (>= 0, development)

Gem executable-hooks-1.3.2
  tf (>= 0, development)

Gem ffi-1.9.14
  rake (~> 10.1, development)
  rake-compiler (~> 0.9, development)
  rake-compiler-dock (~> 0.5.2, development)
  rspec (~> 2.14.1, development)
  rubygems-tasks (~> 0.2.4, development)

Gem gem-wrappers-1.2.7
  minitest (>= 0, development)
  rake (>= 0, development)

Gem globalid-0.3.7
  activesupport (>= 4.1.0)
  rake (>= 0, development)

Gem hashery-2.1.2
  lemon (>= 0, development)
  qed (>= 0, development)
  rubytest-cli (>= 0, development)

Gem hashie-3.4.6
  rake (>= 0, development)
  rspec (~> 3.0, development)
  rspec-pending_for (~> 0.1, development)

Gem httplog-0.3.3
  colorize (>= 0)
  ethon (>= 0, development)
  excon (>= 0.18.0, development)
  faraday (>= 0, development)
  guard-rspec (>= 0, development)
  http (= 1.0.4, development)
  httparty (>= 0, development)
  httpclient (>= 0, development)
  log4r (>= 0, development)
  patron (>= 0, development)
  rack (>= 0, development)
  rake (>= 0, development)
  rspec (>= 0, development)
  simplecov (>= 0, development)
  thin (>= 0, development)
  typhoeus (>= 0, development)

Gem i18n-0.7.0

Gem ims-lti-1.1.13
  builder (>= 0)
  oauth (< 0.6, >= 0.4.5)
  rspec (>= 0, development)

Gem io-console-0.4.6

Gem jbuilder-2.6.0
  activesupport (< 5.1, >= 3.0.0)
  multi_json (~> 1.2)

Gem jquery-rails-4.2.1
  rails-dom-testing (< 3, >= 1)
  railties (>= 4.2.0)
  thor (< 2.0, >= 0.14)

Gem jquery-ui-rails-5.0.5
  json (~> 1.7, development)
  railties (>= 3.2.16)

Gem json-2.0.2
  rake (>= 0, development)
  test-unit (~> 2.0, development)

Gem jwt-1.5.6
  bundler (>= 0, development)
  codeclimate-test-reporter (>= 0, development)
  json (< 2.0, development)
  rake (>= 0, development)
  rspec (>= 0, development)
  simplecov (>= 0, development)
  simplecov-json (>= 0, development)

Gem listen-3.0.8
  bundler (>= 1.3.5, development)
  rb-fsevent (>= 0.9.4, ~> 0.9)
  rb-inotify (>= 0.9.7, ~> 0.9)

Gem loofah-2.0.3
  hoe (~> 3.13, development)
  hoe-bundler (>= 0, development)
  hoe-debugging (>= 0, development)
  hoe-gemspec (>= 0, development)
  hoe-git (>= 0, development)
  json (>= 0, development)
  minitest (~> 2.2, development)
  nokogiri (>= 1.5.9)
  rake (>= 0.8, development)
  rdoc (~> 4.0, development)
  rr (~> 1.1.0, development)

Gem mail-2.6.4
  bundler (>= 1.0.3, development)
  mime-types (< 4, >= 1.16)
  rake (> 0.8.7, development)
  rdoc (>= 0, development)
  rspec (~> 3.0, development)

Gem method_source-0.8.2
  bacon (~> 1.1.0, development)
  rake (~> 0.9, development)

Gem mime-types-3.1
  fivemat (~> 1.3, development)
  hoe (~> 3.15, development)
  hoe-doofus (~> 1.0, development)
  hoe-gemspec2 (~> 1.1, development)
  hoe-git (~> 1.6, development)
  hoe-rubygems (~> 1.0, development)
  hoe-travis (~> 1.2, development)
  mime-types-data (~> 3.2015)
  minitest (~> 5.9, development)
  minitest-autotest (~> 1.0, development)
  minitest-bonus-assertions (~> 2.0, development)
  minitest-focus (~> 1.0, development)
  minitest-hooks (~> 1.4, development)
  minitest-rg (~> 5.2, development)
  rake (~> 10.0, development)
  rdoc (~> 4.0, development)
  simplecov (~> 0.7, development)

Gem mime-types-data-3.2016.0521
  hoe (~> 3.15, development)
  hoe-doofus (~> 1.0, development)
  hoe-gemspec2 (~> 1.1, development)
  hoe-git (~> 1.6, development)
  hoe-rubygems (~> 1.0, development)
  mime-types (~> 3.0, development)
  nokogiri (~> 1.6, development)
  rake (~> 10.0, development)
  rdoc (~> 4.0, development)

Gem mini_portile2-2.1.0
  bundler (~> 1.7, development)
  minitar (~> 0.5.4, development)
  minitest (~> 5.8.0, development)
  minitest-hooks (~> 1.4.0, development)
  rake (~> 10.0, development)

Gem minitest-5.9.1
  hoe (~> 3.15, development)
  rdoc (~> 4.0, development)

Gem minitest-5.10.1
  hoe (~> 3.15, development)
  rdoc (~> 4.0, development)

Gem multi_json-1.12.1
  bundler (~> 1.0, development)

Gem multi_xml-0.6.0
  bundler (~> 1.0, development)

Gem multipart-post-2.0.0

Gem net-telnet-0.1.1
  bundler (~> 1.9, development)
  rake (~> 10.0, development)

Gem nio4r-1.2.1
  bundler (>= 0, development)
  rake (>= 0, development)

Gem nio4r-2.0.0
  bundler (>= 0, development)
  rake (>= 0, development)

Gem nokogiri-1.6.8.1
  hoe (~> 3.15, development)
  hoe-bundler (~> 1.2.0, development)
  hoe-debugging (~> 1.2.1, development)
  hoe-gemspec (~> 1.0.0, development)
  hoe-git (~> 1.6.0, development)
  mini_portile2 (~> 2.1.0)
  minitest (~> 5.8.4, development)
  racc (~> 1.4.14, development)
  rake (~> 10.5.0, development)
  rake-compiler (~> 0.9.2, development)
  rake-compiler-dock (~> 0.5.1, development)
  rdoc (~> 4.0, development)
  rexical (~> 1.0.5, development)

Gem nokogiri-1.7.0
  hoe (~> 3.15, development)
  hoe-bundler (~> 1.2.0, development)
  hoe-debugging (~> 1.2.1, development)
  hoe-gemspec (~> 1.0.0, development)
  hoe-git (~> 1.6.0, development)
  mini_portile2 (~> 2.1.0)
  minitest (~> 5.8.4, development)
  racc (~> 1.4.14, development)
  rake (~> 10.5.0, development)
  rake-compiler (~> 0.9.2, development)
  rake-compiler-dock (~> 0.5.1, development)
  rdoc (~> 4.0, development)
  rexical (~> 1.0.5, development)

Gem oauth-0.5.1
  actionpack (>= 4.0.2, development)
  byebug (>= 0, development)
  curb (>= 0, development)
  em-http-request (= 0.2.11, development)
  iconv (>= 0, development)
  minitest (>= 0, development)
  mocha (>= 0.9.12, development)
  rack (>= 0, development)
  rack-test (>= 0, development)
  rake (>= 0, development)
  typhoeus (>= 0.1.13, development)

Gem openssl-2.0.2
  rake (>= 0, development)
  rake-compiler (>= 0, development)
  rdoc (>= 0, development)
  test-unit (~> 3.0, development)

Gem pg-0.19.0
  hoe (~> 3.12, development)
  hoe-bundler (~> 1.0, development)
  hoe-deveiate (~> 0.7, development)
  hoe-highline (~> 0.2, development)
  hoe-mercurial (~> 1.4, development)
  rake-compiler (~> 0.9, development)
  rake-compiler-dock (~> 0.5, development)
  rdoc (~> 4.0, development)
  rspec (~> 3.0, development)

Gem power_assert-0.4.1
  rake (>= 0, development)
  simplecov (>= 0, development)
  test-unit (>= 0, development)

Gem psych-2.2.2
  minitest (~> 5.0, development)
  rake-compiler (>= 0.4.1, development)

Gem public_suffix-2.0.5
  mocha (>= 0, development)
  rake (>= 0, development)
  yard (>= 0, development)

Gem puma-3.6.0
  hoe (~> 3.15, development)
  rack (< 2.0, >= 1.1, development)
  rake-compiler (~> 0.8, development)
  rdoc (~> 4.0, development)

Gem rack-1.6.5
  bacon (>= 0, development)
  rake (>= 0, development)

Gem rack-2.0.1
  concurrent-ruby (>= 0, development)
  minitest (~> 5.0, development)
  minitest-sprint (>= 0, development)
  rake (>= 0, development)

Gem rack-test-0.6.3
  rack (>= 1.0)

Gem rails-5.0.0.1
  actioncable (= 5.0.0.1)
  actionmailer (= 5.0.0.1)
  actionpack (= 5.0.0.1)
  actionview (= 5.0.0.1)
  activejob (= 5.0.0.1)
  activemodel (= 5.0.0.1)
  activerecord (= 5.0.0.1)
  activesupport (= 5.0.0.1)
  bundler (< 2.0, >= 1.3.0)
  railties (= 5.0.0.1)
  sprockets-rails (>= 2.0.0)

Gem rails-5.0.1
  actioncable (= 5.0.1)
  actionmailer (= 5.0.1)
  actionpack (= 5.0.1)
  actionview (= 5.0.1)
  activejob (= 5.0.1)
  activemodel (= 5.0.1)
  activerecord (= 5.0.1)
  activesupport (= 5.0.1)
  bundler (< 2.0, >= 1.3.0)
  railties (= 5.0.1)
  sprockets-rails (>= 2.0.0)

Gem rails-dom-testing-2.0.1
  activesupport (< 6.0, >= 4.2.0)
  bundler (~> 1.3, development)
  minitest (>= 0, development)
  nokogiri (~> 1.6.0)
  rake (>= 0, development)

Gem rails-dom-testing-2.0.2
  activesupport (< 6.0, >= 4.2.0)
  bundler (~> 1.3, development)
  minitest (>= 0, development)
  nokogiri (~> 1.6)
  rake (>= 0, development)

Gem rails-html-sanitizer-1.0.3
  bundler (~> 1.3, development)
  loofah (~> 2.0)
  minitest (>= 0, development)
  rails-dom-testing (>= 0, development)
  rake (>= 0, development)

Gem railties-5.0.0.1
  actionpack (= 5.0.0.1)
  actionview (= 5.0.0.1, development)
  activesupport (= 5.0.0.1)
  method_source (>= 0)
  rake (>= 0.8.7)
  thor (< 2.0, >= 0.18.1)

Gem railties-5.0.1
  actionpack (= 5.0.1)
  actionview (= 5.0.1, development)
  activesupport (= 5.0.1)
  method_source (>= 0)
  rake (>= 0.8.7)
  thor (< 2.0, >= 0.18.1)

Gem rake-11.3.0
  bundler (~> 1.11, development)
  minitest (~> 5.8, development)
  rdoc (~> 4.0, development)

Gem rake-12.0.0
  bundler (>= 0, development)
  minitest (>= 0, development)
  rdoc (>= 0, development)

Gem rb-fsevent-0.9.8
  bundler (~> 1.0, development)
  guard-rspec (~> 4.2, development)
  rspec (~> 2.11, development)

Gem rb-inotify-0.9.7
  ffi (>= 0.5.0)
  yard (>= 0.4.0, development)

Gem rdoc-5.0.0
  kpeg (>= 0, development)
  minitest (~> 4, development)
  racc (> 1.4.10, development)
  rake (>= 0, development)

Gem ruby-ole-1.2.12

Gem ruby-rc4-0.1.5
  rspec (>= 0, development)

Gem rubygems-bundler-1.4.4
  bundler-unload (>= 1.0.2)
  executable-hooks (>= 1.3.2)
  tf (>= 0, development)

Gem rubyzip-1.2.0
  coveralls (~> 0.7, development)
  minitest (~> 5.4, development)
  pry (~> 0.10, development)
  rake (~> 10.3, development)

Gem rvm-1.11.3.9

Gem sass-3.4.22
  maruku (>= 0.5.9, development)
  minitest (>= 5, development)
  yard (>= 0.5.3, development)

Gem sass-3.4.23
  maruku (>= 0.5.9, development)
  minitest (>= 5, development)
  yard (>= 0.5.3, development)

Gem sass-rails-5.0.6
  railties (< 6, >= 4.0.0)
  sass (~> 3.1)
  sprockets (< 4.0, >= 2.8)
  sprockets-rails (< 4.0, >= 2.0)
  sqlite3 (>= 0, development)
  tilt (< 3, >= 1.1)

Gem socksify-1.7.0

Gem spring-2.0.0
  activesupport (>= 4.2)
  bump (>= 0, development)
  rake (>= 0, development)

Gem spring-watcher-listen-2.0.1
  activesupport (>= 0, development)
  bundler (~> 1.6, development)
  listen (< 4.0, >= 2.7)
  rake (>= 0, development)
  spring (< 3.0, >= 1.2)

Gem sprockets-3.7.0
  closure-compiler (~> 1.1, development)
  coffee-script (~> 2.2, development)
  coffee-script-source (~> 1.6, development)
  concurrent-ruby (~> 1.0)
  eco (~> 1.0, development)
  ejs (~> 1.0, development)
  execjs (~> 2.0, development)
  minitest (~> 5.0, development)
  nokogiri (~> 1.3, development)
  rack (< 3, > 1)
  rack-test (~> 0.6, development)
  rake (~> 10.0, development)
  sass (~> 3.1, development)
  uglifier (~> 2.3, development)
  yui-compressor (~> 0.12, development)

Gem sprockets-3.7.1
  closure-compiler (~> 1.1, development)
  coffee-script (~> 2.2, development)
  coffee-script-source (~> 1.6, development)
  concurrent-ruby (~> 1.0)
  eco (~> 1.0, development)
  ejs (~> 1.0, development)
  execjs (~> 2.0, development)
  minitest (~> 5.0, development)
  nokogiri (~> 1.3, development)
  rack (< 3, > 1)
  rack-test (~> 0.6, development)
  rake (~> 10.0, development)
  sass (~> 3.1, development)
  uglifier (~> 2.3, development)
  yui-compressor (~> 0.12, development)

Gem sprockets-rails-3.2.0
  actionpack (>= 4.0)
  activesupport (>= 4.0)
  railties (>= 4.0, development)
  rake (>= 0, development)
  sass (>= 0, development)
  sprockets (>= 3.0.0)
  uglifier (>= 0, development)

Gem test-unit-3.2.3
  bundler (>= 0, development)
  kramdown (>= 0, development)
  packnga (>= 0, development)
  power_assert (>= 0)
  rake (>= 0, development)
  yard (>= 0, development)

Gem thin-1.7.0
  daemons (>= 1.0.9, ~> 1.0)
  eventmachine (>= 1.0.4, ~> 1.0)
  rack (< 3, >= 1)

Gem thor-0.19.1
  bundler (~> 1.0, development)

Gem thor-0.19.4
  bundler (~> 1.0, development)

Gem thread_safe-0.3.5
  atomic (= 1.1.16, development)
  minitest (>= 4, development)
  rake (>= 0, development)

Gem tilt-2.0.5

Gem ttfunk-1.4.0
  rake (>= 0, development)
  rdoc (>= 0, development)
  rspec (>= 0, development)
  rubocop (= 0.20.1, development)

Gem turbolinks-5.0.1
  turbolinks-source (~> 5)

Gem turbolinks-source-5.0.0

Gem tzinfo-1.2.2
  thread_safe (~> 0.1)

Gem uglifier-3.0.3
  bundler (~> 1.3, development)
  execjs (< 3, >= 0.3.0)
  rake (~> 11.3, development)
  rspec (~> 3.0, development)
  sourcemap (~> 0.1.1, development)

Gem web-console-3.4.0
  actionview (>= 5.0)
  activemodel (>= 5.0)
  debug_inspector (>= 0)
  railties (>= 5.0)

Gem websocket-driver-0.6.4
  eventmachine (>= 0, development)
  permessage_deflate (>= 0, development)
  rake-compiler (~> 0.8.0, development)
  rspec (>= 0, development)
  websocket-extensions (>= 0.1.0)

Gem websocket-extensions-0.1.2
  rspec (>= 0, development)

Gem will_paginate-3.1.5

Gem xmlrpc-0.2.1
  bundler (>= 0, development)
  rake (>= 0, development)
  test-unit (>= 0, development)

Gem zip-zip-0.3
  bundler (~> 1.6, development)
  minitest (= 4.7.5, development)
  pry (>= 0, development)
  rake (>= 0, development)
  rubyzip (>= 1.0.0)

How do I eliminate the dependency on this gem? I thought deleting Gemfile.lock and trying again would work, but evidently, no dice.


Show source
| ruby   | rubygems   | ruby-on-rails   | ruby-on-rails-4   | gemfile   2017-01-04 15:01 1 Answers

Answers to Why does gem dependency list a gem I have commented out in my Gemfile? ( 1 )

  1. 2017-01-04 16:01

    Maybe one of your gems needs JSON-1.8.3 and has it as a dependency for itself.
    Have you tried to comment half of your gems, then run bundle again, and so on until you don't find it in your dependencies anymore? (dichotomy)

Leave a reply to - Why does gem dependency list a gem I have commented out in my Gemfile?

◀ Go back