Trouble with Facebook in app browser, rest of the browsers working perfectly fine

Question

First a little context. I'm a designer from the Netherlands with a love for code. I can find my way pretty ok in html and css and a little bit in php and javascript. I love the Stack Overflow community, it helped me so much and it still helps me every day in becoming a little bit better at coding!

I have never asked a question here at S.O. before, because I always found a way to solve problems, untill now. I literally tried everything and I really hope you guys can help me.

I have a hobby project: https://unboxguide.com It is some kind of TripAdvisor for CrossFit Boxes (gym boxes).

It is a Wordpress website which uses several different plugins for some functionalities. The site works perfect on desktop browsers like Chrome, Safari, Firefox, etc. No problem there. Then on mobile, still no problem there. On Android with chrome, it works perfect, on iPhone with Safari, still shiny.

But then.... the horror starts.

The Facebook in-app browser. There is something completely weird there. If I post a link to the website on Facebook and you click on it in the Facebook app it will open the Facebook in-app browser. The website renders completely randomly. Sometimes it doesn't load fonts, or any of the layout (css). Sometimes it doesn't even load the images.

Some research taught me that it is some kind of webview of the internal Mobile OS browser. So on iPhone a webview of Safari and Android a webview of Chrome.

I tested the Facebook links on Android, no problems there. The problem only occurs in the Facebook app on iPhone.

If you want to see for yourself, post https://unboxguide.com on your Facebook (just do it privately, so only you can see it) and keep refreshing it. The more you refresh, the more random results you will get. It's so strange.

I've tried so many things: rebuild the whole CSS, killed all plugins, tried different themes and tried to build everything from scratch. I also tried different backups from a few months ago where (I thought) the problem didn't occur yet. Nothing helped.

I really really hope someone has had the same issue or understands the problem, and can help or point me in the right direction.

Thanks in advance!

PS: If anything is needed furthermore to help you guys figure out what the problem can be, please let me know and I can post more information.


Show source
| javascript   | html   | css   | iphone   | facebook   2017-01-01 22:01 0 Answers

Answers to Trouble with Facebook in app browser, rest of the browsers working perfectly fine ( 0 )

Leave a reply to - Trouble with Facebook in app browser, rest of the browsers working perfectly fine

◀ Go back