bundle install fails for custom spree gems

Question

I have a spree app running where I am using number of gems to solve some of my purposes.

I am using a gem spree social, spree reviews and a couple more. I had my code and It was working well. But since I have pulled the code, I am getting error like below

Could not find gem 'spree_social' in source at vendor/gems/spree_social. Source does not contain any versions of 'spree_social'

Here's how I've mentioned my gems

 gem 'spree_wishlist' , :path => File.join(File.dirname(__FILE__), '/vendor/gems/spree_wishlist-2.2.0')
 gem 'spree_reviews',  :path => File.join(File.dirname(__FILE__), '/vendor/gems/spree_reviews')
 gem 'spree_social',  :path => File.join(File.dirname(__FILE__), '/vendor/gems/spree_social')
 gem 'spree_gift_card',  :path => File.join(File.dirname(__FILE__), '/vendor/gems/spree_gift_card')
 gem 'stringex'
 gem 'spree_auth_devise',  :path => File.join(File.dirname(__FILE__), '/vendor/gems/spree_auth_devise-3.0.6')  

Someone please help me out in this.


Show source
| ruby   | rubygems   | ruby-on-rails   | gemfile   2016-06-08 11:06 1 Answers

Answers to bundle install fails for custom spree gems ( 1 )

  1. 2016-06-08 13:06

    Why not to do in Gemfile:

    gem 'spree_social', github: 'spree-contrib/spree_social', branch: 'master'. Then run bundle install.

Leave a reply to - bundle install fails for custom spree gems

◀ Go back