When trying to upgrade to Rails 5, getting "Bundler could not find compatible versions for gem "railties"" error
I’m trying to upgrade to Rails 5. I deleted my Gemfile.lock file, edited my Gemfile to look like below
and ran “bundle install”, only to get the below errors
$ bundle install Your Gemfile lists the gem jquery-rails (>= 0) more than once. You should probably keep only one of them. While it's not a problem now, it could cause errors if you change the version of just one of them later. Fetching gem metadata from https://rubygems.org/......... Fetching version metadata from https://rubygems.org/... Fetching dependency metadata from https://rubygems.org/.. Resolving dependencies.............. Bundler could not find compatible versions for gem "railties": In Gemfile: coffee-rails (~> 4.1.0) was resolved to 4.1.1, which depends on railties (< 5.1.x, >= 4.0.0) jquery-modal-rails was resolved to 0.0.1, which depends on railties (< 5.0, >= 3.2.0) jquery-rails was resolved to 4.1.1, which depends on railties (>= 4.2.0) rails (= 5.0.0) was resolved to 5.0.0, which depends on railties (= 5.0.0) sass-rails (~> 5.0) was resolved to 5.0.6, which depends on railties (< 6, >= 4.0.0) web-console (~> 2.0) was resolved to 2.3.0, which depends on railties (>= 4.0)
How do I properly edit my Gemfile so I can upgrade to Rails 5?